配置客户端未连接到 PTC Kepware 产品中的运行时服务

问题描述

配置客户端未连接到 PTC Kepware 产品中的运行时服务

解决方案
适用于

1.KEPServerEX 5.14.493.0 to 6.13

2.ThingWorx Kepware Server 8.0 N/A to 6.13

说明

1.配置客户端未连接到 KEPServerEX/ThingWorxKepware 服务器中的运行时服务

2.配置窗口显示离线状态

3.事件日志显示:错误 KEPServerEX\Configuration 运行时连接尝试失败。 |运行时主机地址 = '127.0.0.1: [端口] ',用户 = '默认用户',原因 = '由于超时期限已过,此操作返回。'。

4.弹出消息: KEPServerEX:未建立连接。重试? (您可以通过选择“否”来离线工作)

原因

1.可用资源有限 32 位应用程序

内存占用高

客户数量过多

过多的客户端标签请求

2.通讯端口设置错误[端口]

3.在同一操作系统上运行的多个 Kepware 实例

解决步骤

原因1

1.检查可用资源 Windows 任务管理器

内存使用情况

项目标签计数高

客户数量过多

活动标签数量过多

(检查配置实用程序屏幕右下角的已连接客户端和活动标签)

 

原因2

验证为配置客户端配置的端口号

1.转至 KEPServerEX 管理 > 设置... > 配置选项卡

2.使用端口设置通信 = 32402 (默认)

原因3

1.KEPServerEx/ThingWorx Kepware Server 是单实例应用程序

2.在任何给定时间,单个操作系统上只能存在一个安装

3.卸载第二个 Kepware 实例